package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]{2}[a-zA-Z0-9]+)`)
var str = `CY99999999L sts wtr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}