$re = '/^(.{0,8}[\)|\.])/m';
$str = '(1dada)test(21d32dd2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);