package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{0,8}[\)|\.])`)
var str = `(1dada)test(21d32dd2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}