re = /^(https?:\/\/)?([\dA-Za-z\.-]+)\.([A-Za-z\.]{2,6})([\/\w \.-]*)*\/?$/m
str = 'free.com
www.hi.co.uk
co.co.jp.ls
http://google.com
Google.Com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end