package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?([\dA-Za-z\.-]+)\.([A-Za-z\.]{2,6})([\/\w \.-]*)*\/?$`)
var str = `free.com
www.hi.co.uk
co.co.jp.ls
http://google.com
Google.Com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}