using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0][0-9]{9}";
string input = @"qqqqqqqqqq
1111111111
345fg42356
43573457356735
fdrdsvgrevfc
0687897498";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}