#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0][0-9]{9}"
Local $sString = "qqqqqqqqqq" & @CRLF & _
"1111111111" & @CRLF & _
"345fg42356" & @CRLF & _
"43573457356735" & @CRLF & _
"fdrdsvgrevfc" & @CRLF & _
"0687897498"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")