import Foundation
let pattern = #"const.*=.*{+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
exports.async_createUser = async (user, required) => {
exports.async_createUser = async (user, required) =>
const test = function(a,b) => {
const test = (a,b) => {
const test = a => {
const async_getInfAuthToken = async () => {
const convertFromStateABV = async abv => {
const customField = infUser.custom_fields.filter(index => {
const thing = new user({
// const thing = new user({
// inf.updateWedding(weddingId);
inf.setMilestoneDate(req.user, 8);
}); //User email >> Spouse email (42)
exports.infCreate = function(req, callback) {
const user = await User.findOne({ _id: wedding.users[numUser] });
const test = function(a,b)
const i = require(./stuff)
// const userC = require("./users");
const User = require("./../models/user");
const Utils = require("./../utils");
const userC = require("./users");
const Wedding = require("./../models/wedding");
const config = require("./../config");
const request = require("request-promise");
const sms = require("./smss");
const email = require("./emails");
const contacts = require("./contacts");
"error [inf.getNumberOfContactsFromWeddingID] : " + //
inf.applyTagToUser(userList[i].inf_id, [ //
// inf.setMilestoneDate(userList[i], 8);
inf.applyTagToUser(u.inf_id, [564]); //[Fulfillment _ 110 _ DLY _ LM _ WT - couples _ v01 _ START]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)