import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "const.*=.*\\{+$";
final String string = "exports.async_createUser = async (user, required) => {\n"
+ "exports.async_createUser = async (user, required) => \n\n"
+ "const test = function(a,b) => {\n"
+ "const test = (a,b) => {\n"
+ "const test = a => {\n"
+ "const async_getInfAuthToken = async () => {\n"
+ "const convertFromStateABV = async abv => {\n"
+ "const customField = infUser.custom_fields.filter(index => {\n"
+ "const thing = new user({\n"
+ "// const thing = new user({\n"
+ "// inf.updateWedding(weddingId);\n"
+ "inf.setMilestoneDate(req.user, 8);\n"
+ "}); //User email >> Spouse email (42)\n"
+ "exports.infCreate = function(req, callback) {\n"
+ "const user = await User.findOne({ _id: wedding.users[numUser] });\n\n"
+ "const test = function(a,b) \n"
+ "const i = require(./stuff)\n"
+ "// const userC = require(\"./users\");\n\n"
+ "const User = require(\"./../models/user\");\n"
+ "const Utils = require(\"./../utils\");\n"
+ "const userC = require(\"./users\");\n"
+ "const Wedding = require(\"./../models/wedding\");\n"
+ "const config = require(\"./../config\");\n"
+ "const request = require(\"request-promise\");\n"
+ "const sms = require(\"./smss\");\n"
+ "const email = require(\"./emails\");\n"
+ "const contacts = require(\"./contacts\");\n\n\n"
+ "\"error [inf.getNumberOfContactsFromWeddingID] : \" + //\n"
+ "inf.applyTagToUser(userList[i].inf_id, [ //\n"
+ "// inf.setMilestoneDate(userList[i], 8);\n"
+ "inf.applyTagToUser(u.inf_id, [564]); //[Fulfillment _ 110 _ DLY _ LM _ WT - couples _ v01 _ START]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}