# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{0,2}.\d{3}.\d{2}(?=<span>PKT<\/span>)"
test_str = " type=\"text/javascript\">$(document).ready(function() { DynamicHeadLineTagResize($('div.snapshot-headline h2.font-resize'), 21, 0); });$(window).on('resize', function() { DynamicHeadLineTagResize($('div.snapshot-headline h2.font-resize'), 21, 0); });</script><div class=\"col-sm-7\"><div class=\"row quotebox\"><div class=\"col-xs-5 col-sm-4 text-sm-right text-nowrap\">13.161,08<span>PKT</span></div><div class=\"col-xs-4 col-sm-3 text-sm-right text-nowrap text-center red\">-21,48<span>PKT</span></div><div class=\"col-xs-3 col-sm-3 text-right text-nowrap red\">-0,16<span>%</span></div><div class=\"col-sm-2 col-xs-12 text-sm-right quotebox-option\"><div class=\"quotebox-time quotebox-time-bottom\">11:36:05 Uhr</div></div></div><div class=\"row hidden-xs relative\"><div class=\"col-xs-12\"><div class=\"pull-sm-right\"><div class=\"small-font light-grey pull-left mleft-sm-10 hidden-xs\">Anzeige</div>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.