const regex = /\d{0,2}.\d{3}.\d{2}(?=<span>PKT<\/span>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{0,2}.\\d{3}.\\d{2}(?=<span>PKT<\\\/span>)', 'g')
const str = ` type="text/javascript">\$(document).ready(function() { DynamicHeadLineTagResize(\$('div.snapshot-headline h2.font-resize'), 21, 0); });\$(window).on('resize', function() { DynamicHeadLineTagResize(\$('div.snapshot-headline h2.font-resize'), 21, 0); });</script><div class="col-sm-7"><div class="row quotebox"><div class="col-xs-5 col-sm-4 text-sm-right text-nowrap">13.161,08<span>PKT</span></div><div class="col-xs-4 col-sm-3 text-sm-right text-nowrap text-center red">-21,48<span>PKT</span></div><div class="col-xs-3 col-sm-3 text-right text-nowrap red">-0,16<span>%</span></div><div class="col-sm-2 col-xs-12 text-sm-right quotebox-option"><div class="quotebox-time quotebox-time-bottom">11:36:05 Uhr</div></div></div><div class="row hidden-xs relative"><div class="col-xs-12"><div class="pull-sm-right"><div class="small-font light-grey pull-left mleft-sm-10 hidden-xs">Anzeige</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}