$re = '/君が好き.*/m';
$str = '君が好きです。
君が好きかもね。
君が好きだっちゅうの。';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);