using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"君が好き.*";
string input = @"君が好きです。
君が好きかもね。
君が好きだっちゅうの。";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}