# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})):(\d{5})"
test_str = ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
"<html xmlns=\"http://www.w3.org/1999/xhtml\" xml:lang=\"en\" lang=\"en\">\n"
" <head>\n"
" <meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" />\n"
" <meta name=\"title\" content=\"eBot :: Your ingame bot manager for CS:GO\" />\n"
" <title>eBot :: Your ingame bot manager for CS:GO</title>\n"
" <link rel=\"shortcut icon\" type=\"image/png\" href=\"/favicon.png\" />\n"
" <link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/bootstrap.min.css\" />\n"
"<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/bootstrap-responsive.min.css\" />\n"
"<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/tipsy.css\" />\n"
"<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/datatable.bootstrap.css\" />\n"
"<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/flags.css\" />\n"
"<link rel=\"stylesheet\" type=\"text/css\" media=\"screen\" href=\"/css/hubinfo.min.css\" />\n"
" <script type=\"text/javascript\" src=\"/js/jquery-1.8.2.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/bootstrap.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/jquery.validate.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/jquery.tipsy.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/jquery.tablesorter.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/jquery.datatable.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/datatable.bootstrap.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/heatmap.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/raphael-min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/jquery.iphone-switch.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/hubinfo.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/pnotify.custom.min.js\"></script>\n"
"<script type=\"text/javascript\" src=\"/js/aes.js\"></script>\n"
" <style type=\"text/css\">\n"
" body {\n"
" padding-top: 60px;\n"
" padding-bottom: 40px;\n"
" }\n"
" .sidebar-nav {\n"
" padding: 9px 0;\n"
" }\n"
" </style>\n"
" <!-- Le HTML5 shim, for IE6-8 support of HTML5 elements -->\n"
" <!--[if lt IE 9]>\n"
" <script src=\"http://html5shim.googlecode.com/svn/trunk/html5.js\"></script>\n"
" <![endif]-->\n"
" </head>\n"
" <body>\n"
" <script>\n"
" function submitForm(id) {\n"
" $(\"#\" + id).submit();\n"
" }\n\n"
" var socketIoAddress = \"176.31.211.228:12370\";\n"
" var socket = null;\n"
" var socketIoLoaded = false;\n"
" var loadingSocketIo = false;\n"
" var callbacks = new Array();\n"
" function initSocketIo(callback) {\n"
" callbacks.push(callback);\n"
" if (loadingSocketIo) {\n"
" return;\n"
" }\n"
" \n"
" if (socketIoLoaded) {\n"
" if (typeof callback == \"function\") {\n"
" callback(socket);\n"
" }\n"
" return;\n"
" }\n"
" \n"
" loadingSocketIo = true;\n"
" $.getScript(\"http://\"+socketIoAddress+\"/socket.io/socket.io.js\", function(){\n"
" socket = io.connect(\"http://\"+socketIoAddress);\n"
" socket.on('connect', function(){ \n"
" socketIoLoaded = true;\n"
" loadingSocketIo = false;\n"
" if (typeof callback == \"function\") {\n"
" callback(socket);\n"
" }\n"
" for (var c in callbacks) {\n"
" callbacks[c](socket);\n"
" }\n"
" //callbacks = new Array();\n"
" });\n"
" });\n"
" }\n"
" </script>\n"
" <div class=\"navbar navbar-inverse navbar-fixed-top\">\n"
" <div class=\"navbar-inner\">\n"
" <div class=\"container-fluid\">\n"
" <a class=\"btn btn-navbar\" data-toggle=\"collapse\" data-target=\".nav-collapse\">\n"
" <span class=\"icon-bar\"></span>\n"
" <span class=\"icon-bar\"></span>\n"
" <span class=\"icon-bar\"></span>\n"
" </a>\n"
" <a class=\"brand\" href=\"/\">eBot-CSGO</a>\n"
" <div class=\"nav-collapse collapse\">\n"
" <div style=\"line-height: 35px; float: right; margin-right: 10px;\">\n"
" <form style=\"display:inline; margin-left: 5px; cursor: pointer\" action=\"/switch/lang/fr\" method=\"POST\" id=\"langFr\"><input type=\"hidden\" name=\"referer\" value=\"/servers\" /><img onclick=\"javascript:submitForm('langFr')\" src=\"/images/fr.png\" /></form>\n"
" <form style=\"display:inline; margin-left: 5px; cursor: pointer\" action=\"/switch/lang/en\" method=\"POST\" id=\"langEn\"><input type=\"hidden\" name=\"referer\" value=\"/servers\" /><img onclick=\"javascript:submitForm('langEn')\" src=\"/images/en.png\" /></form>\n"
" <form style=\"display:inline; margin-left: 5px; cursor: pointer\" action=\"/switch/lang/de\" method=\"POST\" id=\"langDe\"><input type=\"hidden\" name=\"referer\" value=\"/servers\" /><img onclick=\"javascript:submitForm('langDe')\" src=\"/images/de.png\" /></form>\n"
" <form style=\"display:inline; margin-left: 5px; cursor: pointer\" action=\"/switch/lang/cn\" method=\"POST\" id=\"langCn\"><input type=\"hidden\" name=\"referer\" value=\"/servers\" /><img onclick=\"javascript:submitForm('langCn')\" src=\"/images/cn.gif\" /></form>\n"
" </div>\n"
" \n"
" <p class=\"navbar-text pull-right\">\n"
" Logged in as <a href=\"#\" class=\"navbar-link\">tictax</a>\n"
" </p>\n"
" <ul class=\"nav\">\n"
" <li class=\"active\"><a href=\"/\">Home</a></li>\n"
" <li><a href=\"http://www.esport-tools.net/ebot\">Help</a></li>\n"
" <li><a href=\"http://www.esport-tools.net/about\">About</a></li>\n"
" </ul>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n\n"
" <div class=\"container-fluid\">\n"
" <div class=\"row-fluid\">\n"
" <div class=\"span2\">\n"
" <div class=\"well sidebar-nav\">\n"
" <script>\n"
" function goToMatch() {\n"
" var id = $(\"#match_id_go\").val();\n"
" if (id > 0)\n"
" document.location.href = \"/matchs/view/\"+id;\n"
" };\n"
" </script>\n"
" <ul class=\"nav nav-list\">\n"
" <li class=\"nav-header\">Main Menu</li>\n"
" <li ><a href=\"/\">Home</a></li>\n"
" <li ><a href=\"/stats\">Statistics</a></li>\n"
" <li ><a href=\"/credits\">Credits</a></li>\n"
" <!--<li ><a href=\"/main/ingame\">Ingame Help</a></li>-->\n"
" <li class=\"nav-header\">Match Menu</li>\n"
" <li ><a href=\"/matchs/current/1\">Matches in Progress <span class=\"badge badge-info\">39</span></a></li>\n"
" <li ><a href=\"/matchs/archived/1\">Archived Matches</a></li>\n"
" <li ><a href=\"/seasons\">Seasons Overview</a></li>\n"
" <li class=\"nav-header\">Match Management</li>\n"
" <li ><a href=\"/matchs/create\">Create a match</a></li>\n"
" <li ><a href=\"/matchs/user\">My matchs <span class=\"badge badge-info\">0</span></a></li>\n"
" <li class=\"nav-header\">Team Management</li>\n"
" <li><a href=\"/teams/create\">Create Team</a></li>\n"
" <li><a href=\"/teams\">Team Management</a></li>\n"
" <li class=\"nav-header\">Server Management</li>\n"
" <li ><a href=\"/servers/create\">Add Gameserver</a></li>\n"
" <li><a href=\"/servers\">Server Management</a></li>\n"
" <li class=\"nav-header\">Statistics</li>\n"
" <li ><a href=\"/stats/global\">Global Statistics</a></li>\n"
" <li ><a href=\"/stats/maps\">Statistics by Map</a></li>\n"
" <li ><a href=\"/stats/weapons\">Statistics by Weapon</a></li>\n"
" </ul>\n"
" </div>\n"
"</div>\n"
" <div class=\"span10\">\n"
" \n"
" \n"
" <h3>Server Management (1/2)</h3>\n"
"<hr/>\n"
"<table class=\"table table-striped\">\n"
" <thead>\n"
" <tr>\n"
" <th>#ID</th>\n"
" <th>IP Adress</th>\n"
" <th>Name</th>\n"
" <th>used?</th>\n"
" <th>Action</th>\n"
" </tr>\n"
" </thead>\n"
" <tbody>\n"
" <tr>\n"
" <td width=\"30\">3243</td>\n"
" <td width=\"200\">85.14.230.26:27015</td>\n"
" <td>Xylonm Gameserver</td>\n"
" <td width=\"100\">\n"
" <img src=\"/images/icons/flag_red.png\" /> not used </td>\n"
" <td width=\"100\">\n"
" <a href=\"/servers/delete/3243\"><button class=\"btn btn-danger\">Delete</button></a>\n"
" </td>\n"
" </tr>\n"
" </tbody>\n\n"
"</table> </div>\n"
" </div>\n\n"
" <!-- Please, don't remove the brand -->\n"
" <footer class=\"footer\">\n"
" <p>© <a target=\"_blank\" href=\"http://www.esport-tools.net/ebot\">eSport-tools</a> 2012-2013 - 3.1.0 Public - By deStrO & Basert - Follow me on <a target=\"_blank\" href=\"https://twitter.com/deStrO_BE\">Twitter</a> - Propulsed by <a target=\"_blank\" href=\"http://twitter.github.com/bootstrap\">Bootstrap</a> & <a target=\"_blank\" href=\"http://www.symfony-project.com\">Symfony</a> - Follow eBot on <a target=\"_blank\" href=\"https://github.com/deStrO/eBot-CSGO\">GitHub</a></p>\n"
" </footer>\n\n"
"<form action=\"https://www.paypal.com/cgi-bin/webscr\" method=\"post\" target=\"_top\">\n"
"<input type=\"hidden\" name=\"cmd\" value=\"_donations\">\n"
"<input type=\"hidden\" name=\"business\" value=\"destro@esport-tools.net\">\n"
"<input type=\"hidden\" name=\"lc\" value=\"BE\">\n"
"<input type=\"hidden\" name=\"item_name\" value=\"eSport-tools.net\">\n"
"<input type=\"hidden\" name=\"no_note\" value=\"0\">\n"
"<input type=\"hidden\" name=\"currency_code\" value=\"EUR\">\n"
"<input type=\"hidden\" name=\"bn\" value=\"PP-DonationsBF:btn_donateCC_LG.gif:NonHostedGuest\">\n"
"<input type=\"image\" src=\"https://www.paypalobjects.com/en_US/BE/i/btn/btn_donateCC_LG.gif\" border=\"0\" name=\"submit\" alt=\"PayPal - The safer, easier way to pay online!\">\n"
"<img alt=\"\" border=\"0\" src=\"https://www.paypalobjects.com/fr_XC/i/scr/pixel.gif\" width=\"1\" height=\"1\">\n"
"</form>\n"
" </div>\n"
" <script type=\"text/javascript\">\n\n"
" var _gaq = _gaq || [];\n"
" _gaq.push(['_setAccount', 'UA-22008669-4']);\n"
" _gaq.push(['_trackPageview']);\n\n"
" (function() {\n"
" var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;\n"
" ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';\n"
" var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);\n"
" })();\n\n"
"</script>\n"
" </body>\n"
"</html>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.