using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})):(\d{5})";
string input = @"<!DOCTYPE html PUBLIC ""-//W3C//DTD XHTML 1.0 Transitional//EN"" ""http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"">
<html xmlns=""http://www.w3.org/1999/xhtml"" xml:lang=""en"" lang=""en"">
<head>
<meta http-equiv=""Content-Type"" content=""text/html; charset=utf-8"" />
<meta name=""title"" content=""eBot :: Your ingame bot manager for CS:GO"" />
<title>eBot :: Your ingame bot manager for CS:GO</title>
<link rel=""shortcut icon"" type=""image/png"" href=""/favicon.png"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/bootstrap.min.css"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/bootstrap-responsive.min.css"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/tipsy.css"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/datatable.bootstrap.css"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/flags.css"" />
<link rel=""stylesheet"" type=""text/css"" media=""screen"" href=""/css/hubinfo.min.css"" />
<script type=""text/javascript"" src=""/js/jquery-1.8.2.min.js""></script>
<script type=""text/javascript"" src=""/js/bootstrap.min.js""></script>
<script type=""text/javascript"" src=""/js/jquery.validate.min.js""></script>
<script type=""text/javascript"" src=""/js/jquery.tipsy.js""></script>
<script type=""text/javascript"" src=""/js/jquery.tablesorter.min.js""></script>
<script type=""text/javascript"" src=""/js/jquery.datatable.min.js""></script>
<script type=""text/javascript"" src=""/js/datatable.bootstrap.js""></script>
<script type=""text/javascript"" src=""/js/heatmap.js""></script>
<script type=""text/javascript"" src=""/js/raphael-min.js""></script>
<script type=""text/javascript"" src=""/js/jquery.iphone-switch.js""></script>
<script type=""text/javascript"" src=""/js/hubinfo.min.js""></script>
<script type=""text/javascript"" src=""/js/pnotify.custom.min.js""></script>
<script type=""text/javascript"" src=""/js/aes.js""></script>
<style type=""text/css"">
body {
padding-top: 60px;
padding-bottom: 40px;
}
.sidebar-nav {
padding: 9px 0;
}
</style>
<!-- Le HTML5 shim, for IE6-8 support of HTML5 elements -->
<!--[if lt IE 9]>
<script src=""http://html5shim.googlecode.com/svn/trunk/html5.js""></script>
<![endif]-->
</head>
<body>
<script>
function submitForm(id) {
$(""#"" + id).submit();
}
var socketIoAddress = ""176.31.211.228:12370"";
var socket = null;
var socketIoLoaded = false;
var loadingSocketIo = false;
var callbacks = new Array();
function initSocketIo(callback) {
callbacks.push(callback);
if (loadingSocketIo) {
return;
}
if (socketIoLoaded) {
if (typeof callback == ""function"") {
callback(socket);
}
return;
}
loadingSocketIo = true;
$.getScript(""http://""+socketIoAddress+""/socket.io/socket.io.js"", function(){
socket = io.connect(""http://""+socketIoAddress);
socket.on('connect', function(){
socketIoLoaded = true;
loadingSocketIo = false;
if (typeof callback == ""function"") {
callback(socket);
}
for (var c in callbacks) {
callbacks[c](socket);
}
//callbacks = new Array();
});
});
}
</script>
<div class=""navbar navbar-inverse navbar-fixed-top"">
<div class=""navbar-inner"">
<div class=""container-fluid"">
<a class=""btn btn-navbar"" data-toggle=""collapse"" data-target="".nav-collapse"">
<span class=""icon-bar""></span>
<span class=""icon-bar""></span>
<span class=""icon-bar""></span>
</a>
<a class=""brand"" href=""/"">eBot-CSGO</a>
<div class=""nav-collapse collapse"">
<div style=""line-height: 35px; float: right; margin-right: 10px;"">
<form style=""display:inline; margin-left: 5px; cursor: pointer"" action=""/switch/lang/fr"" method=""POST"" id=""langFr""><input type=""hidden"" name=""referer"" value=""/servers"" /><img onclick=""javascript:submitForm('langFr')"" src=""/images/fr.png"" /></form>
<form style=""display:inline; margin-left: 5px; cursor: pointer"" action=""/switch/lang/en"" method=""POST"" id=""langEn""><input type=""hidden"" name=""referer"" value=""/servers"" /><img onclick=""javascript:submitForm('langEn')"" src=""/images/en.png"" /></form>
<form style=""display:inline; margin-left: 5px; cursor: pointer"" action=""/switch/lang/de"" method=""POST"" id=""langDe""><input type=""hidden"" name=""referer"" value=""/servers"" /><img onclick=""javascript:submitForm('langDe')"" src=""/images/de.png"" /></form>
<form style=""display:inline; margin-left: 5px; cursor: pointer"" action=""/switch/lang/cn"" method=""POST"" id=""langCn""><input type=""hidden"" name=""referer"" value=""/servers"" /><img onclick=""javascript:submitForm('langCn')"" src=""/images/cn.gif"" /></form>
</div>
<p class=""navbar-text pull-right"">
Logged in as <a href=""#"" class=""navbar-link"">tictax</a>
</p>
<ul class=""nav"">
<li class=""active""><a href=""/"">Home</a></li>
<li><a href=""http://www.esport-tools.net/ebot"">Help</a></li>
<li><a href=""http://www.esport-tools.net/about"">About</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class=""container-fluid"">
<div class=""row-fluid"">
<div class=""span2"">
<div class=""well sidebar-nav"">
<script>
function goToMatch() {
var id = $(""#match_id_go"").val();
if (id > 0)
document.location.href = ""/matchs/view/""+id;
};
</script>
<ul class=""nav nav-list"">
<li class=""nav-header"">Main Menu</li>
<li ><a href=""/"">Home</a></li>
<li ><a href=""/stats"">Statistics</a></li>
<li ><a href=""/credits"">Credits</a></li>
<!--<li ><a href=""/main/ingame"">Ingame Help</a></li>-->
<li class=""nav-header"">Match Menu</li>
<li ><a href=""/matchs/current/1"">Matches in Progress <span class=""badge badge-info"">39</span></a></li>
<li ><a href=""/matchs/archived/1"">Archived Matches</a></li>
<li ><a href=""/seasons"">Seasons Overview</a></li>
<li class=""nav-header"">Match Management</li>
<li ><a href=""/matchs/create"">Create a match</a></li>
<li ><a href=""/matchs/user"">My matchs <span class=""badge badge-info"">0</span></a></li>
<li class=""nav-header"">Team Management</li>
<li><a href=""/teams/create"">Create Team</a></li>
<li><a href=""/teams"">Team Management</a></li>
<li class=""nav-header"">Server Management</li>
<li ><a href=""/servers/create"">Add Gameserver</a></li>
<li><a href=""/servers"">Server Management</a></li>
<li class=""nav-header"">Statistics</li>
<li ><a href=""/stats/global"">Global Statistics</a></li>
<li ><a href=""/stats/maps"">Statistics by Map</a></li>
<li ><a href=""/stats/weapons"">Statistics by Weapon</a></li>
</ul>
</div>
</div>
<div class=""span10"">
<h3>Server Management (1/2)</h3>
<hr/>
<table class=""table table-striped"">
<thead>
<tr>
<th>#ID</th>
<th>IP Adress</th>
<th>Name</th>
<th>used?</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td width=""30"">3243</td>
<td width=""200"">85.14.230.26:27015</td>
<td>Xylonm Gameserver</td>
<td width=""100"">
<img src=""/images/icons/flag_red.png"" /> not used </td>
<td width=""100"">
<a href=""/servers/delete/3243""><button class=""btn btn-danger"">Delete</button></a>
</td>
</tr>
</tbody>
</table> </div>
</div>
<!-- Please, don't remove the brand -->
<footer class=""footer"">
<p>© <a target=""_blank"" href=""http://www.esport-tools.net/ebot"">eSport-tools</a> 2012-2013 - 3.1.0 Public - By deStrO & Basert - Follow me on <a target=""_blank"" href=""https://twitter.com/deStrO_BE"">Twitter</a> - Propulsed by <a target=""_blank"" href=""http://twitter.github.com/bootstrap"">Bootstrap</a> & <a target=""_blank"" href=""http://www.symfony-project.com"">Symfony</a> - Follow eBot on <a target=""_blank"" href=""https://github.com/deStrO/eBot-CSGO"">GitHub</a></p>
</footer>
<form action=""https://www.paypal.com/cgi-bin/webscr"" method=""post"" target=""_top"">
<input type=""hidden"" name=""cmd"" value=""_donations"">
<input type=""hidden"" name=""business"" value=""destro@esport-tools.net"">
<input type=""hidden"" name=""lc"" value=""BE"">
<input type=""hidden"" name=""item_name"" value=""eSport-tools.net"">
<input type=""hidden"" name=""no_note"" value=""0"">
<input type=""hidden"" name=""currency_code"" value=""EUR"">
<input type=""hidden"" name=""bn"" value=""PP-DonationsBF:btn_donateCC_LG.gif:NonHostedGuest"">
<input type=""image"" src=""https://www.paypalobjects.com/en_US/BE/i/btn/btn_donateCC_LG.gif"" border=""0"" name=""submit"" alt=""PayPal - The safer, easier way to pay online!"">
<img alt="" border=""0"" src=""https://www.paypalobjects.com/fr_XC/i/scr/pixel.gif"" width=""1"" height=""1"">
</form>
</div>
<script type=""text/javascript"">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-22008669-4']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
</body>
</html>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}