$re = '/^[A-Z][a-z]*(_[A-Z][a-z]*)*$/m';
$str = 'This_Is_My_C_Public_Function';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);