package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]*(_[A-Z][a-z]*)*$`)
var str = `This_Is_My_C_Public_Function`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}