$re = '/ (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)/xsm';
$str = '{% if something %}
DEEP
{% if something %}
DEEPER
{% endif %}
{% something totally different %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
DEEP
{% endif %}
neue
{% if NODE %}
DEEP
{% if something %}
DEEPER
{% endif %}
{% something totally different %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
DEEP
{% endif %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);