#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsm) (?=" & @CRLF & _
" ({%.if" & @CRLF & _
" (?:" & @CRLF & _
" (?>" & @CRLF & _
" (?:" & @CRLF & _
" (?! {%.if | endif.%}) ." & @CRLF & _
" )+" & @CRLF & _
" )*" & @CRLF & _
" | (?1)" & @CRLF & _
" )*" & @CRLF & _
" endif.%})" & @CRLF & _
" )" & @CRLF & _
" (?1)"
Local $sString = "{% if something %}" & @CRLF & _
" DEEP" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% endif %}" & @CRLF & _
"" & @CRLF & _
"{% something totally different %}" & @CRLF & _
"" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPEST" & @CRLF & _
" {% endif %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% endif %}" & @CRLF & _
" DEEP" & @CRLF & _
"{% endif %}" & @CRLF & _
"" & @CRLF & _
"neue" & @CRLF & _
"" & @CRLF & _
"{% if NODE %}" & @CRLF & _
" DEEP" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% endif %}" & @CRLF & _
"" & @CRLF & _
"{% something totally different %}" & @CRLF & _
"" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% if something %}" & @CRLF & _
" DEEPEST" & @CRLF & _
" {% endif %}" & @CRLF & _
" DEEPER" & @CRLF & _
" {% endif %}" & @CRLF & _
" DEEP" & @CRLF & _
"{% endif %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")