$re = '/[+]{1}[3]{2}[1-7]{1}[0-9]{8}/';
$str = '+33661924254';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);