package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[+]{1}[3]{2}[1-7]{1}[0-9]{8}`)
var str = `+33661924254`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}