$re = '/^\(?([0-9]{2})?\)? ?([0-9]{4,5})-?([0-9]{4})$/';
$str = '(11) 3993-1130';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);