package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\(?([0-9]{2})?\)? ?([0-9]{4,5})-?([0-9]{4})$`)
var str = `(11) 3993-1130`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}