using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""](""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?(""[^""]*""|[^"",]*)[,]?[""]";
string input = @"Year,Make,Model,Description,Price
1997,Ford,E350,""ac, abs, moon"",3000.00
1999,Chevy,""Venture ""Extended Edition"""","",4900.00
1999,Chevy,""Venture ""Extended Edition, Very Large"""",,5000.00
1996,Jeep,Grand Cherokee,""MUST SELL!
air, moon roof, loaded"",4799.00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}