const regex = /\"[^\"]*[\u2E80-\u9FFF]+[^\"]*\"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"[^\\"]*[\\u2E80-\\u9FFF]+[^\\"]*\\"', 'g')
const str = `// case ph_text_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L"填空题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L"解答题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_trueorfalse:
// v[TEST_TYPE_TEXT] = W2U(L"判断题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}