package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"[^\"]*[\u2E80-\u9FFF]+[^\"]*\"`)
var str = `// case ph_text_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L"填空题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_fill_item:
// v[TEST_TYPE_TEXT] = W2U(L"解答题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
// break;
// case ph_text_answer_trueorfalse:
// v[TEST_TYPE_TEXT] = W2U(L"判断题");
// ((CTextRectObj*)pObjs[i])->SetTestAttrs(v);
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}