$re = '/^(\+|\-)?(^:[0-9]{1,2}|[012][0-9]{2}|3[0-5][0-9])$/';
$str = '-255
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);