using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+|\-)?(^:[0-9]{1,2}|[012][0-9]{2}|3[0-5][0-9])$";
string input = @"-255
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}