$re = '/^\p{L}+([\'-]\p{L}+)*\.?(\s\p{L}+([\'-]\p{L}+)*\.?)*$/';
$str = 'Vas dQ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);