package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\p{L}+(['-]\p{L}+)*\.?(\s\p{L}+(['-]\p{L}+)*\.?)*$`)
var str = `Vas dQ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}