re = /([A-Z])([a-z])(.+)/m
str = 'ADDRESSKeller, Brian
asdfasdfdsafdsf
ADDRESS Keller, Brian
ADDRESSKeller, Brian A
ADDRESS Keller, Brian A.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end