package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z])([a-z])(.+)`)
var str = `ADDRESSKeller, Brian
asdfasdfdsafdsf
ADDRESS Keller, Brian
ADDRESSKeller, Brian A
ADDRESS Keller, Brian A.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}