$re = '/\$(\w*)\+\+/';
$str = 'asdf=5
$asdf++';
$subst = "$1=\$(( \$1+1 ))";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;