package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$(\w*)\+\+`)
var str = `asdf=5
$asdf++`
var substitution = "$1=\$(( \$1+1 ))"
fmt.Println(re.ReplaceAllString(str, substitution))
}