const regex = /(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)', 'gm')
const str = `HIT & REPLACE
11/21/1994
12/11/2014
03/31/2016 # Hit only if unchecked for length months/days
NO-HIT
11//12/2090
37/14/2015
20/27/2011
10/32/1964
14/03/2020
HINTS
- Use g-flag only.
`;
const subst = `$1,$1,$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);