import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)";
final String string = "HIT & REPLACE\n"
+ "11/21/1994\n"
+ "12/11/2014\n"
+ "03/31/2016 # Hit only if unchecked for length months/days\n\n"
+ "NO-HIT\n"
+ "11//12/2090\n"
+ "37/14/2015\n"
+ "20/27/2011\n"
+ "10/32/1964\n"
+ "14/03/2020\n\n"
+ "HINTS\n"
+ "- Use g-flag only.\n";
final String subst = "$1,$1,$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}