import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S{3}\\.(\\S+)\\.com|\\S{3}\\.(\\S+)\\.es";
final String string = "/amp.farodevigo.com/gran-vigo/2017/08/30/concello-habilitara-tercera-playa-perros/1741197.html,8,0.00,100.00%,0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}