package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S{3}\.(\S+)\.com|\S{3}\.(\S+)\.es`)
var str = `/amp.farodevigo.com/gran-vigo/2017/08/30/concello-habilitara-tercera-playa-perros/1741197.html,8,0.00,100.00%,0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}