const regex = /(file\/d\/)([a-zA-Z0-9]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(file\\\/d\\\/)([a-zA-Z0-9]*)', '')
const str = `https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}