using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(file\/d\/)([a-zA-Z0-9]*)";
string input = @"https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}