$re = '/{foreach \$(.*) as (?:\$([^ ]*)|\$(.*) => \$(.*))}(.*){\/foreach}/Uis';
$str = '{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);