using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{foreach \$(.*) as (?:\$([^ ]*)|\$(.*) => \$(.*))}(.*){\/foreach}";
string input = @"{foreach $groups as $name => $val} FFFFFFFFFFFFF {/foreach}";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}