const regex = /^(?:(?:(?<protocol>(?:http|https)):\/\/)?(?:(?<authority>(?:[A-Za-z](?:[A-Za-z\d\-]*[A-Za-z\d])?)(?:\.[A-Za-z][A-Za-z\d\-]*[A-Za-z\d])*)(?:\:(?<port>[0-9]+))?\/)(?:(?<path>[^\/][^\?\#\;]*\/))?)?(?<file>[^\?\#\/\\]*\.(?<extension>[Jj][Pp][Ee]?[Gg]|[Pp][Nn][Gg]|[Gg][Ii][Ff]))(?:\?(?<query>[^\#]*))?(?:\#(?<fragment>.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?<protocol>(?:http|https)):\\\/\\\/)?(?:(?<authority>(?:[A-Za-z](?:[A-Za-z\\d\\-]*[A-Za-z\\d])?)(?:\\.[A-Za-z][A-Za-z\\d\\-]*[A-Za-z\\d])*)(?:\\:(?<port>[0-9]+))?\\\/)(?:(?<path>[^\\\/][^\\?\\#\\;]*\\\/))?)?(?<file>[^\\?\\#\\\/\\\\]*\\.(?<extension>[Jj][Pp][Ee]?[Gg]|[Pp][Nn][Gg]|[Gg][Ii][Ff]))(?:\\?(?<query>[^\\#]*))?(?:\\#(?<fragment>.*))?$', 'gm')
const str = `https://www.somedomain.com:8080/path1/path2/test.jpeg?version=1.2&size-medium#54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}