import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?<protocol>(?:http|https)):\\/\\/)?(?:(?<authority>(?:[A-Za-z](?:[A-Za-z\\d\\-]*[A-Za-z\\d])?)(?:\\.[A-Za-z][A-Za-z\\d\\-]*[A-Za-z\\d])*)(?:\\:(?<port>[0-9]+))?\\/)(?:(?<path>[^\\/][^\\?\\#\\;]*\\/))?)?(?<file>[^\\?\\#\\/\\\\]*\\.(?<extension>[Jj][Pp][Ee]?[Gg]|[Pp][Nn][Gg]|[Gg][Ii][Ff]))(?:\\?(?<query>[^\\#]*))?(?:\\#(?<fragment>.*))?$";
final String string = "https://www.somedomain.com:8080/path1/path2/test.jpeg?version=1.2&size-medium#54";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}