package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SET(\d+)`)
var str = `fdgiods;jgfgs;djfogSET032dfgdfgdf fdg sdfg sdfg dg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}