using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SET(\d+)";
string input = @"fdgiods;jgfgs;djfogSET032dfgdfgdf fdg sdfg sdfg dg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}