// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^()[\]{}<>]*)(\(((?1)(?2)*)*\)|\[(?3)*\]|<(?3)*>|{(?3)*})(?1)$").unwrap();
let string = "sd{f(tagsad<fas>df(tag(a)sd)sdfa(sdf)s[a(sd)]f)as}df";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}