$re = '/^([^()[\]{}<>]*)(\(((?1)(?2)*)*\)|\[(?3)*\]|<(?3)*>|{(?3)*})(?1)$/';
$str = 'sd{f(tagsad<fas>df(tag(a)sd)sdfa(sdf)s[a(sd)]f)as}df';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);