$re = '/(<\w+)(\s*[\w-]+="[^"]+")*(\s*data-toggle="[^"]+")(\s*[\w-]+="[^"]+")*(\s*>)/';
$str = '<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<td class="sky" data-toggle="up" id="heaven" >
<a href="#" data-toggle="modal" data-target="xxxx"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>
';
$subst = "$1$3$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;