using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\w+)(\s*[\w-]+=""[^""]+"")*(\s*data-toggle=""[^""]+"")(\s*[\w-]+=""[^""]+"")*(\s*>)";
string substitution = @"$1$3$5";
string input = @"<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<td class=""sky"" data-toggle=""up"" id=""heaven"" >
<a href=""#"" data-toggle=""modal"" data-target=""xxxx""></a>
<a href=""#""data-target=""#available-assistance"" data-toggle=""modal"" data-modal=""yeah""></a>
<a href=""#""data-target=""#available-assistance"" data-toggle=""modal"" data-modal=""yeah""></a>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}